View Issue Details

IDProjectCategoryView StatusLast Update
0003670PartBugpublic2021-02-06 06:46
Reporter0kko Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status confirmedResolutionopen 
Product Version0.17 
Target Version0.20 
Summary0003670: Thickness operation for part fails (upstream OCC bug)
DescriptionThickness operation in Part and Part Design -workbences fails with: "BRep_API: command not done."
Steps To ReproduceSelect "face 8" in "case.fcstd".
Try to do "Thickness"
Additional InformationBinaries tested with "case.fcstd"

FreeCAD-0.17.13541.9948ee4.glibc2.17-x86_64.AppImage
FreeCAD-0.17.13541.9948ee4.glibc2.17-x86_64.AppImage

Note: Issue is reproducible on latest v0.19 since the bug is with upstream OCCT
This ticket is being tracked via OCC Bugs in the Bugtracker forum thread
TagsOCC Bug, OCC NotOnRoadmap, upstream
FreeCAD Information

Activities

Kunda1

2018-11-05 18:37

administrator   ~0012137

@0kko Please check with 0.18_pre appImage to see if you can recreate. https://github.com/FreeCAD/FreeCAD/releases/tag/0.18_pre
(make sure you backup you file before doing so as 0.18 is not backward compatible if you open said file in 0.17 again)

BTW, your ticket does not follow our guidelines stated in the enormous banner at the top of this page. We ask for people to report their issues on the forum first, many times they don't even make it to the tracker because they either get solved, or there is an open ticket already (there are exceptions). You also tested this on 0.17 yet you labeled this 0.18. + we have no idea what OS or OS version you are running. Guidelines are there for a reason, thank you.

normandc

2018-11-11 05:58

manager   ~0012171

Last edited: 2018-11-11 06:01

View 3 revisions

It is no surprise that the Thickness operation fails - look at the corners at the joint between the wedge and the box. The fillet created a deep cavity at the four corners.

While this may look like a separate and legitimate bug (a fillet causing a crease between slanted corners), fixing it does not solve the thickness issue. The thickness command is notoriously weak. It is most probably an upstream (OCC) issue over which the FreeCAD team has no control.

It is indeed exasperating that some people are completely blind to the f***ing huge yellow banner at the top. IMO we should start ruthlessly closing reports that do not comply with rules. Enough with this.

chrisb

2020-12-22 00:33

developer   ~0015166

File is lost, and it was as Normand guessed most probably an OCC issue anyway.

wmayer

2020-12-22 11:53

administrator   ~0015173

https://forum.freecadweb.org/viewtopic.php?f=8&t=53514&p=460091#p460091

Kunda1

2020-12-22 12:13

administrator   ~0015174

Reopening and tracking via OCC Bugs in the Bugtracker forum thread

Kunda1

2020-12-22 12:15

administrator   ~0015175

Re-uploaded attachment since previous one was broken. Thanks wmayer ;)
case.fcstd (203,881 bytes)

Issue History

Date Modified Username Field Change
2018-11-05 08:03 0kko New Issue
2018-11-05 08:04 0kko File Added: case.fcstd
2018-11-05 18:37 Kunda1 Note Added: 0012137
2018-11-05 18:38 Kunda1 Status new => feedback
2018-11-05 18:38 Kunda1 Product Version 0.18 => 0.17
2018-11-05 18:38 Kunda1 Steps to Reproduce Updated View Revisions
2018-11-05 18:38 Kunda1 Additional Information Updated View Revisions
2018-11-11 05:58 normandc Note Added: 0012171
2018-11-11 06:00 normandc Note Edited: 0012171 View Revisions
2018-11-11 06:01 normandc Note Edited: 0012171 View Revisions
2018-11-14 11:56 wmayer Status feedback => confirmed
2020-12-22 00:33 chrisb Assigned To => chrisb
2020-12-22 00:33 chrisb Status confirmed => closed
2020-12-22 00:33 chrisb Resolution open => unable to reproduce
2020-12-22 00:33 chrisb Note Added: 0015166
2020-12-22 11:53 wmayer Note Added: 0015173
2020-12-22 12:13 Kunda1 Assigned To chrisb =>
2020-12-22 12:13 Kunda1 Status closed => confirmed
2020-12-22 12:13 Kunda1 Note Added: 0015174
2020-12-22 12:14 Kunda1 Summary Thickness operation for part fails => Thickness operation for part fails (upstream OCC bug)
2020-12-22 12:14 Kunda1 Description Updated View Revisions
2020-12-22 12:14 Kunda1 File Deleted: case.fcstd
2020-12-22 12:15 Kunda1 Note Added: 0015175
2020-12-22 12:15 Kunda1 File Added: case.fcstd
2020-12-22 12:15 Kunda1 Tag Attached: OCC Bug
2020-12-22 12:15 Kunda1 Tag Attached: OCC NotOnRoadmap
2020-12-22 12:15 Kunda1 Tag Attached: upstream
2020-12-22 12:18 Kunda1 Resolution unable to reproduce => open
2020-12-22 12:18 Kunda1 Additional Information Updated View Revisions
2020-12-22 12:18 Kunda1 Additional Information Updated View Revisions
2020-12-22 12:19 Kunda1 Severity major => minor
2021-02-06 06:46 abdullah Target Version => 0.20