View Issue Details

IDProjectCategoryView StatusLast Update
0003544FreeCADBugpublic2018-10-04 16:40
Reporterdevincprescott Assigned Towmayer  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformNTL CL6OSGallium OS (Ubuntu)OS VersionGOS 2.1 (16.04)
Product Version0.17 
Fixed in Version0.18 
Summary0003544: Crash on creation of vertical dimension with Shift + V
DescriptionFreeCAD crashes while trying to create a vertical dimension with the Shift + V command after sketching a circle, dimensioning its radius, creating a reference edge, then attempting to insert a vertical dimension.
Steps To Reproduce0. Open Part
1. Create Sketch on XZ
2. Draw Circle (Mouse Click on circle from tool bar)
3. Dimension Radius (Shift + R)
5. Clear Tool Selection (ESC)
4. Pickup Top Edge of Part (X)
6. Clear Tool Selection (ESC)
7. Attempt to create verticle measurement (Shift + V)
8. Crash
Additional InformationOS: GalliumOS 2.1
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13522 (Git) AppImage
Build type: None
Branch: releases/FreeCAD-0-17
Hash: 3bb5ff4e70c0c526f2d9dd69b1004155b2f527f2
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: English/UnitedStates (en_US)
Tagscrash, Sketch, sketcher
FreeCAD Information

Activities

devincprescott

2018-07-21 19:26

reporter   ~0011540

Adding File to reproduce.
stock_mount.fcstd (Attachment missing)
Create Sketch on XZ Plane (Attachment missing)
Dimension Radius.png (Attachment missing)
Reference Top Face.png (Attachment missing)

Kunda1

2018-07-27 13:51

administrator   ~0011546

@devincprescott is #3543 a duplicate that can be deleted?
also...Thank you for the reports, to minimize tracker bloat, please kindly follow our guidelines for opening tickets on our bugtracker (big yellow banner at the top of this page)

devincprescott

2018-07-27 14:39

reporter   ~0011554

Hi Kunda1,

Yes, 0003543 is a duplicate, I started filling it out but it froze when submitted, so I resubmitted and then notice both posted. I looked (briefly) for a way to delete it but was unable to find one.

I attempted to follow the format in the big yellow banner, but wasn't really sure where to post in the forum. I don't see an issues related forum topic; should it be under "General Discussion?"

Thanks,
Devin Prescott

Kunda1

2018-10-02 21:12

administrator   ~0011896

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=31304

DeepSOIC

2018-10-02 21:40

developer   ~0011898

Reproduced.
Clarifications:

0. Open Part
1. Create Sketch on XZ

devicprescott
0. The file has no Part in it. I guess you meant just the file.

1. I created the sketch from PartDesign workbench (while one can also create one from Sketcher WB, one will not end up in body).

4. Pickup Top Edge of Part (X)
The edge was not accepted (not imported into sketcher).
7. Don't preselect anything, just apply the constraint. The preselected edge that wasn't accepted seems to be the source of the trouble.

TheMarkster

2018-10-04 03:19

reporter   ~0011910

7. Don't preselect anything, just apply the constraint. The preselected edge that wasn't accepted seems to be the source of the trouble.

DeepSOIC

Yes, I agree. Clicking in empty 3d space clears the remnant preselection and seems to prevent the crash.

https://github.com/FreeCAD/FreeCAD/pull/1711

wmayer

2018-10-04 16:35

administrator   ~0011921

The problem goes much deeper. The actual reason of the crash is that it's nowhere checked that the first object of the selection is really a sketch. Independent of the real type it's cast to a SketchObject and thus leaves back an invalid object.

wmayer

2018-10-04 16:40

administrator   ~0011922

https://github.com/FreeCAD/FreeCAD/commit/abb56c35d0e6ee63c9db18e6f91d989fc0ac047a

Issue History

Date Modified Username Field Change
2018-07-21 19:25 devincprescott New Issue
2018-07-21 19:25 devincprescott Tag Attached: crash
2018-07-21 19:25 devincprescott Tag Attached: Sketch
2018-07-21 19:25 devincprescott Tag Attached: sketcher
2018-07-21 19:26 devincprescott File Added: stock_mount.fcstd
2018-07-21 19:26 devincprescott File Added: Create Sketch on XZ Plane
2018-07-21 19:26 devincprescott File Added: Dimension Radius.png
2018-07-21 19:26 devincprescott File Added: Reference Top Face.png
2018-07-21 19:26 devincprescott Note Added: 0011540
2018-07-27 13:51 Kunda1 Note Added: 0011546
2018-07-27 13:51 Kunda1 Status new => feedback
2018-07-27 14:39 devincprescott Note Added: 0011554
2018-07-27 14:39 devincprescott Status feedback => new
2018-10-02 21:12 Kunda1 Note Added: 0011896
2018-10-02 21:40 DeepSOIC Note Added: 0011898
2018-10-03 16:08 Kunda1 Status new => feedback
2018-10-04 03:19 TheMarkster Note Added: 0011910
2018-10-04 16:35 wmayer Note Added: 0011921
2018-10-04 16:40 wmayer Assigned To => wmayer
2018-10-04 16:40 wmayer Status feedback => closed
2018-10-04 16:40 wmayer Resolution open => fixed
2018-10-04 16:40 wmayer Fixed in Version => 0.18
2018-10-04 16:40 wmayer Note Added: 0011922