View Issue Details

IDProjectCategoryView StatusLast Update
0003523FreeCADBugpublic2020-03-27 13:32
Reporterger08061959 Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version0.17 
Summary0003523: Crash (after installing PySide2) with segmentation fault
DescriptionSheet Metal workbench loaded
nurbs configuration file loaded
During initialization the error 'module' object has no attribute 'getModulePath' occurred in /home/ger/.FreeCAD/Mod/Cfd/InitGui.py
Please look into the log file for further information
ERROR 1: libgrass_dgl.7.4.1.so: cannot open shared object file: No such file or directory
ERROR 1: libgrass_dgl.7.4.1.so: cannot open shared object file: No such file or directory
ERROR 1: libgrass_vector.7.4.1.so: cannot open shared object file: No such file or directory
ERROR 1: libgrass_vector.7.4.1.so: cannot open shared object file: No such file or directory
Program received signal SIGSEGV, Segmentation fault.
#0 /lib/x86_64-linux-gnu/libc.so.6(+0x3ef20) [0x7f5993d0cf20]
#1 /lib/x86_64-linux-gnu/libc.so.6(+0x190e30) [0x7f5993e5ee30]
0000002 /home/ger/.local/lib/python2.7/site-packages/PySide2/Qt/lib/libQt5Core.so.5(+0x278a88) [0x7f590c8b8a88]
0000003 0x7f590c8bb951 in QMetaType::registerNormalizedType(QByteArray const&, void (*)(void*), void* (*)(void*, void const*), int, QFlags<QMetaType::TypeFlag>, QMetaObject const*) from /home/ger/.local/lib/python2.7/site-packages/PySide2/Qt/lib/libQt5Core.so.5+0x61
0000004 /home/ger/.local/lib/python2.7/site-packages/PySide2/QtCore.so(+0x2138c6) [0x7f590ddae8c6]
0000005 /home/ger/.local/lib/python2.7/site-packages/PySide2/QtCore.so(initQtCore+0x4b) [0x7f590de3333b]
0000006 /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(_PyImport_LoadDynamicModule+0x9b) [0x7f599599ccab]
0000007 /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(+0x1d4afe) [0x7f5995a20afe]
Steps To ReproduceStart the stable version after installing pyside2 from qt website
TagsNo tags attached.
FreeCAD Information

Activities

ger08061959

2018-07-02 02:34

reporter   ~0011478

Last edited: 2018-07-02 03:13

View 2 revisions

Recompiling with Qt5 disabled still includes Qt5 and pyside2 and gives same crash.cd, recompiling with QT5 switch off, ensure nothing of pyside2 is referred to, still references to the pyside2 libraries, which crash.

Uninstall (pip uninstall pyside2) removes the crashing problem.

Kunda1

2018-07-03 02:12

administrator   ~0011481

@ger08061959 please follow the instructions in the large yellow banner at the top of any of the FC tracker pages. You have not provided enough information for us to help you. Please also open a forum thread to discuss this with the community.

ger08061959

2018-07-03 17:48

reporter   ~0011490

I saw the big yellow banner:
1. No post found that stable version 0.17 would crash after installing pyside2.
2. Programs loads a few workbenches than crashes with given trace (started via console to get trace)
3. Program seems to load a few workbenches (as seen) but version 0.17 never get up and running.
4. Can't post version info as progrma crashes.
5. Program does not start so there is not a specific example where it crashes. It crashes before anything is done.

Problems seems to be in the pyside2 module. If present it disrupt even stable version re-installed, source version does not compile with QT5 (requires pyside but cmake can't find), nor does work when compile with Qt 4 (can't load any module because lacking system modules from pyside2 (??))

What's the way to get FreeCAD compile with Qt5 so I can make use of the newer 3D?

Kunda1

2018-07-05 00:29

administrator   ~0011493

@ger08061959 like I said, the guidelines state to open a forum thread to discuss with the community directly. There are very established forum threads that discuss QT5 and py3 porting. Here is a quick example: https://forum.freecadweb.org/viewtopic.php?f=4&t=26754&p=234989

@looo please weigh in. Thanks!

Kunda1

2019-06-20 07:24

administrator   ~0013277

@ger08061959 is this still presenting as an issue ?

Kunda1

2020-01-06 16:23

administrator   ~0013999

@ger08061959 ping

Kunda1

2020-03-27 13:32

administrator   ~0014306

No response from OP. closing ticket

Issue History

Date Modified Username Field Change
2018-07-02 02:19 ger08061959 New Issue
2018-07-02 02:34 ger08061959 Note Added: 0011478
2018-07-02 03:13 ger08061959 Note Edited: 0011478 View Revisions
2018-07-03 02:12 Kunda1 Status new => feedback
2018-07-03 02:12 Kunda1 Note Added: 0011481
2018-07-03 17:48 ger08061959 Note Added: 0011490
2018-07-03 17:48 ger08061959 Status feedback => new
2018-07-05 00:29 Kunda1 Note Added: 0011493
2019-06-20 07:24 Kunda1 Status new => feedback
2019-06-20 07:24 Kunda1 Note Added: 0013277
2020-01-06 16:23 Kunda1 Note Added: 0013999
2020-03-27 13:32 Kunda1 Status feedback => closed
2020-03-27 13:32 Kunda1 Resolution open => no change required
2020-03-27 13:32 Kunda1 Note Added: 0014306