View Issue Details

IDProjectCategoryView StatusLast Update
0003512SketcherBugpublic2018-06-19 05:47
Reporterseaturtle Assigned Tochrisb  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformMacOSMac OS X 
Product Version0.17 
Summary0003512: Drag select in Sketcher is offset on Retina display (high DPI)
DescriptionThe drag select function when editing a sketch is offset upward by a very large amount on Retina displays, making it difficult to select elements. This does not happen on non-Retina displays.
Steps To Reproduce- Create a new sketch.
- Move the window to a Retina display (if it isn't already there).
- Try to drag-select. If you get near the bottom of the window, you may see the selection box near the top.
Additional InformationFreeCAD version information:

OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13519 (Git)
Build type: Release
Branch: (HEAD detached at 1a8b868)
Hash: 1a8b868018f45ea486c0023fdbfeb06febc1fb89
Python version: 2.7.14
Qt version: 5.10.1
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: English/UnitedStates (en_US)

Screenshot:

[img]
TagsNo tags attached.
FreeCAD Information

Relationships

duplicate of 0003130 closedwmayer FreeCAD FreeCAD 0.17 Qt5 bugs with external display 

Activities

Kunda1

2018-06-17 10:52

administrator   ~0011445

@seaturtle
* screenshot did not successfully upload,
* please test on 0.18dev https://github.com/FreeCAD/FreeCAD/releases/tag/0.18_pre
* please open a forum thread in the future to discuss tickets with the community per our bug tracking guidelines stated at the top of the page.
Thank you

Issue History

Date Modified Username Field Change
2018-06-15 16:41 seaturtle New Issue
2018-06-17 10:52 Kunda1 Status new => feedback
2018-06-17 10:52 Kunda1 Note Added: 0011445
2018-06-19 05:47 chrisb Assigned To => chrisb
2018-06-19 05:47 chrisb Status feedback => closed
2018-06-19 05:47 chrisb Resolution open => duplicate
2018-06-19 05:47 chrisb Relationship added duplicate of 0003130