View Issue Details

IDProjectCategoryView StatusLast Update
0003436PartDesignBugpublic2020-06-13 17:55
Reporterdbecad Assigned Toabdullah  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformLinusOSUbuntu  
Product Version0.18 
Target Version0.19Fixed in Version0.19 
Summary0003436: Fillet edge crash FC
DescriptionFilet of the edge indicated crash FC completely, was reproduced by ChrisB.
Forum thread
Thanks for your hard work!
Cheers
---------
OS: Ubuntu 16.04.4 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.13548 (Git)
Build type: None
Branch: master
Hash: 32973995423007a59cd18799c63383150811d1a7
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: English/UnitedStates (en_US)
Steps To Reproduce-Open PhoneStand_repro.FCStd file
-Select Part workbench
-Fillet indicated edge -> crash
https://forum.freecadweb.org/download/file.php?id=56929 (see attachment below)
Tagsfillet
FreeCAD Information

Activities

dbecad

2018-04-19 20:36

reporter  

PhoneStand_repro.FCStd (81,429 bytes)

Kunda1

2018-10-17 20:57

administrator   ~0012060

Crash still exists:
OS: macOS High Sierra (10.13)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.14957 (Git)
Build type: Release
Branch: (HEAD detached at 22513600d)
Hash: 22513600ddc11a8d0d392f67225d443b7dc2e5bb
Python version: 2.7.15
Qt version: 5.11.2
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: German/Germany (de_DE)

normandc

2018-10-18 01:59

manager   ~0012063

No crash here, only a "Failed to create fillet" error.

And I believe as has been already mentioned in the topic, setting the last Pad's Refine property to true fixes the problem and the fillet succeeds.

OS: Ubuntu 18.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.14979 (Git)
Build type: Release
Branch: master
Hash: 47536dcd3729d3db106af628d62f2bf449e68c49
Python version: 2.7.15rc1
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/Canada (fr_CA)

wmayer

2019-02-24 11:39

administrator   ~0012736

It depends on with which options OCCT was built. If inside the file ooct_defs-flags.cmake this part was commented out:

set (CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -DNo_Exception")
set (CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -DNo_Exception")
then OCCT is built with exception handling. In this case OCCT raises an error instead of simply crashing.

The relevant part of the call stack is:


ChFi3d_Builder::PerformIntersectionAtEnd ChFi3d_Builder_C1.cxx 1678
ChFi3d_Builder::PerformFilletOnVertex ChFi3d_Builder.cxx 735
ChFi3d_Builder::Compute ChFi3d_Builder.cxx 303
BRepFilletAPI_MakeFillet::Build BRepFilletAPI_MakeFillet.cxx 534
PartDesign::Fillet::execute FeatureFillet.cpp 101
App::DocumentObject::recompute DocumentObject.cpp 90

OCCT

Kunda1

2019-06-20 01:38

administrator  

ticket4023.png (27,289 bytes)   
ticket4023.png (27,289 bytes)   

abdullah

2020-06-13 15:07

manager   ~0014528

I cannot reproduce this crash with:

OS: Ubuntu 18.04.4 LTS (MATE/mate)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.
Build type: Release
Branch: unknown
Hash: 8ed90c858645e7562d9534265b6025d39ab4ffd6
Python version: 3.6.9
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0

abdullah

2020-06-13 15:32

manager   ~0014531

Could you please check if this continue to be reproducible?

chrisb

2020-06-13 17:55

developer   ~0014533

No longer reproducible with this version. Now correctly an error raised.

OS: macOS High Sierra (10.13)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.21329 (Git)
Build type: Release
Branch: master
Hash: 2330eef823b32ac412d839031cc174353a76b013
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)

Issue History

Date Modified Username Field Change
2018-04-19 20:36 dbecad New Issue
2018-04-19 20:36 dbecad Tag Attached: fillet
2018-04-19 20:36 dbecad File Added: PhoneStand_repro.FCStd
2018-04-20 21:22 Kunda1 Status new => confirmed
2018-04-20 21:22 Kunda1 Target Version => 0.18
2018-10-17 20:57 Kunda1 Note Added: 0012060
2018-10-18 01:59 normandc Note Added: 0012063
2019-02-24 11:39 wmayer Note Added: 0012736
2019-02-24 11:39 wmayer Target Version 0.18 => 0.19
2019-06-20 01:38 Kunda1 Steps to Reproduce Updated View Revisions
2019-06-20 01:38 Kunda1 File Added: ticket4023.png
2020-06-13 15:07 abdullah Note Added: 0014528
2020-06-13 15:32 abdullah Assigned To => abdullah
2020-06-13 15:32 abdullah Status confirmed => feedback
2020-06-13 15:32 abdullah Note Added: 0014531
2020-06-13 17:55 chrisb Status feedback => closed
2020-06-13 17:55 chrisb Resolution open => unable to reproduce
2020-06-13 17:55 chrisb Fixed in Version => 0.19
2020-06-13 17:55 chrisb Note Added: 0014533