View Issue Details

IDProjectCategoryView StatusLast Update
0003361ExpressionsBugpublic2019-11-09 12:52
Reporter3DME Assigned Toeivindkvedalen  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionreopened 
Product Version0.17 
Target Version0.18Fixed in Version0.18 
Summary0003361: Spreadsheet: Inserting Row Cause Crash - FC Daily v0.17
DescriptionInserting a row in spreadsheet at row-2 causes FreeCAD to crash.

Help --> About FreeCAD, Version Info:
OS: Ubuntu 16.04.4 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13331 (Git)
Build type: None
Branch: master
Hash: e5ef0f532d7e733c581d587cb1c4796237912e03
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0aFollowing
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)
Steps To ReproduceTo re-create the problem:
Open the project,
select the spreadsheet workbench,
open the spreadsheet,
right-click mouse on row-2 and select insert row, then FreeCAD crashes.

Additional InformationClick on the link below for additional information and to down load project files:

Link To Original Report: "On help using FreeCAD" Forum ...
TagsNo tags attached.
FreeCAD Information

Relationships

has duplicate 0003390 closedeivindkvedalen FreeCAD FreeCAD crashes when inserting rows or columns into spreadsheet 

Activities

3DME

2018-03-02 01:09

reporter  

FreeCad_Debug_Terminal_text.txt (Attachment missing)
Spredsheet_1X_9PTS-Grouped_Cuts.fcstd (Attachment missing)
FC_0.17_SS_Crash_1.png (Attachment missing)
FC_0.17_SS_Crash_2.png (Attachment missing)

wmayer

2018-03-25 11:40

administrator   ~0011056

https://github.com/FreeCAD/FreeCAD/commit/f485a0786f238b1c555b2dc8a5d511d5cf8c3e24

eivindkvedalen

2018-03-25 18:26

developer   ~0011057

This is still unresolved, I think. I registered this as another (3390), but later found out that it was already here.

Kunda1

2018-06-26 00:11

administrator   ~0011472

Assigning to eivindkvedalen since 0003390 was opened and assigned to you.

Kunda1

2018-07-31 22:59

administrator   ~0011570

https://github.com/FreeCAD/FreeCAD/commit/d2f9ab6a111975fce69c7f29bf3b7ecb8673a2db

Related Changesets

FreeCAD: master 13da3dd8

2018-07-29 12:37:23

Eivind Kvedalen


Committer: Yorik van Havre Details Diff
Revert "fixes 0003361: Spreadsheet: Inserting Row Cause Crash - FC Daily v0.17"

This reverts commit f485a0786f238b1c555b2dc8a5d511d5cf8c3e24.
Affected Issues
0003361
mod - src/Mod/Spreadsheet/App/PropertySheet.cpp Diff File

Issue History

Date Modified Username Field Change
2018-03-02 01:09 3DME New Issue
2018-03-02 01:09 3DME File Added: FreeCad_Debug_Terminal_text.txt
2018-03-02 01:09 3DME File Added: Spredsheet_1X_9PTS-Grouped_Cuts.fcstd
2018-03-02 01:09 3DME File Added: FC_0.17_SS_Crash_1.png
2018-03-02 01:09 3DME File Added: FC_0.17_SS_Crash_2.png
2018-03-03 10:28 Kunda1 Project FreeCAD => Expressions
2018-03-03 10:29 Kunda1 Status new => confirmed
2018-03-24 08:41 eivindkvedalen Assigned To => eivindkvedalen
2018-03-24 08:41 eivindkvedalen Status confirmed => assigned
2018-03-24 08:44 eivindkvedalen Relationship added has duplicate 0003390
2018-03-25 11:40 wmayer Status assigned => closed
2018-03-25 11:40 wmayer Resolution open => fixed
2018-03-25 11:40 wmayer Fixed in Version => 0.17
2018-03-25 11:40 wmayer Note Added: 0011056
2018-03-25 18:26 eivindkvedalen Status closed => feedback
2018-03-25 18:26 eivindkvedalen Resolution fixed => reopened
2018-03-25 18:26 eivindkvedalen Note Added: 0011057
2018-06-26 00:10 Kunda1 Target Version => 0.18
2018-06-26 00:10 Kunda1 Description Updated
2018-06-26 00:11 Kunda1 Status feedback => assigned
2018-06-26 00:11 Kunda1 Note Added: 0011472
2018-06-26 00:12 Kunda1 Fixed in Version 0.17 =>
2018-07-31 22:59 Kunda1 Status assigned => closed
2018-07-31 22:59 Kunda1 Fixed in Version => 0.18
2018-07-31 22:59 Kunda1 Note Added: 0011570
2019-11-09 12:52 Kunda1 Changeset attached => FreeCAD master 13da3dd8