View Issue Details

IDProjectCategoryView StatusLast Update
0003358PathBugpublic2018-03-08 11:31
Reportersliptonic Assigned Tosliptonic  
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Target Version0.17 
Summary0003358: Simulation of Path with dressup causes crash
DescriptionAttempting to run the simulation of a Path with a Dressup causes a segfault and hard crash.
Steps To Reproduce1) Create a Path Job.
2) Add a contour operation.
3) Select the operation and add a dressup (tested with leadinout and tag but probably affects all)
4) Select either the dressup or the job and click the Simulate button.
5) click the 'play' button.

Additional InformationThe crash appears to be happening because the simulation can't find the associated tool controller. The dressup doesn't have its own TC but uses the TC of the base operation. Simulation should take this into account.
TagsNo tags attached.
FreeCAD Information

Issue History

Date Modified Username Field Change
2018-02-28 19:45 sliptonic New Issue
2018-03-08 11:28 wmayer Assigned To => sliptonic
2018-03-08 11:28 wmayer Status new => closed
2018-03-08 11:28 wmayer Resolution open => fixed
2018-03-08 11:28 wmayer Note Added: 0011020
2018-03-08 11:31 wmayer Note Edited: 0011020 View Revisions