View Issue Details

IDProjectCategoryView StatusLast Update
0003191FreeCADBugpublic2017-10-18 12:11
ReporterKarenRei Assigned Towmayer  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Fixed in Version0.17 
Summary0003191: Readily reproducible memory leak - FreeCAD doesn't reclaim memory on object deletion / project close.
DescriptionAs in the summary. Deleting objects and closing projects doesn't free memory. Eventually FreeCAD will run the system out of memory when you keep repeating the same workflow.
Steps To Reproduce1. Save the attached .dae file in /tmp
2. Run the attached python workflow in the console (you'll see some errors at the end due to a different bug related to unicode, but they don't matter)
3. Note the memory usage in top.
4. Close the project (without closing FreeCAD) and go back to step 2.

Each time, on my system at least, it consumes an additional ~ 10% memory. And right now I'm using a rather simplified model.

In addition to closing projects not freeing memory, manually deleting individual objects doesn't appear to free memory either. The only thing that ever seems to get the memory back is closing and restarting FreeCAD.
Additional InformationOS: "Fedora release 24 (Twenty Four)"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.12122 (Git)
Build type: Unknown
Branch: master
Hash: 501729a84cd0aeef0ae2fcf24cc832eafaf0fa13
Python version: 2.7.13
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 6.8.0.oce-0.17
Locale: Icelandic/Iceland (is_IS)
Tagsmemory leak
FreeCAD Information

Relationships

related to 0003025 closedwmayer Unhandled unknown exception caught in GUIApplication::notify when opening file + memory leak 

Activities

KarenRei

2017-09-17 15:12

reporter  

tmp.dae (Attachment missing)
fem.py (Attachment missing)

Kunda1

2017-09-30 11:34

administrator   ~0010216

Added forum thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=24692

wmayer

2017-10-18 12:11

administrator   ~0010316

Looks like the observed memory leak was caused by the tree view which is fixed now.

Issue History

Date Modified Username Field Change
2017-09-17 15:12 KarenRei New Issue
2017-09-17 15:12 KarenRei File Added: tmp.dae
2017-09-17 15:12 KarenRei File Added: fem.py
2017-09-30 11:27 Kunda1 Steps to Reproduce Updated
2017-09-30 11:28 Kunda1 Tag Attached: memory leak
2017-09-30 11:28 Kunda1 Tag Attached: #post-to-forum
2017-09-30 11:31 Kunda1 Summary Readily reproducable memory leak - FreeCAD doesn't reclaim memory on object deletion / project close. => Readily reproducible memory leak - FreeCAD doesn't reclaim memory on object deletion / project close.
2017-09-30 11:34 Kunda1 Note Added: 0010216
2017-09-30 11:34 Kunda1 Tag Detached: #post-to-forum
2017-09-30 11:36 Kunda1 Relationship added related to 0003025
2017-10-18 12:11 wmayer Assigned To => wmayer
2017-10-18 12:11 wmayer Status new => closed
2017-10-18 12:11 wmayer Resolution open => fixed
2017-10-18 12:11 wmayer Fixed in Version => 0.17
2017-10-18 12:11 wmayer Note Added: 0010316