View Issue Details

IDProjectCategoryView StatusLast Update
0002806FreeCADBugpublic2017-02-10 23:54
Reportereasyw-fc Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformallOSallOS Versionall
Product Version0.17 
Summary0002806: Loading a boolean objects Transparency get lost
DescriptionHi,
 in FC 0.17 (9088 64b on win10 64b) when I save a part that is a result of a simple cut boolean operation, the transparency works and it is saved on the file, but get lost in visualization when the file is reloaded.
This behavior is not present on FC 0.16 (6706 64b on win10 64b) and also reloading the file transparency appearance is fine.
This seems to happen only on boolean operation between colored parts

Please note that in FC 0.17 the Transparency value is fine, and the part get the right appearance if I just modify the value with the gui
FC 0.17 7745 64b behaves correctly
Steps To Reproduceexample files and steps here
http://forum.freecadweb.org/viewtopic.php?f=8&t=18814#p146649
TagsPart, transparency
FreeCAD Information

Relationships

duplicate of 0001029 closedyorik FreeCAD Transparency lost in compound 
related to 0001626 new FreeCAD Transparency not respected when highlighting 
related to 0000848 closedabdullah PartDesign [PartDesign] Keep Transparency and Colors when adding a feature 

Activities

Kunda1

2017-01-28 12:20

administrator  

transparency-prob-fc-0.17.PNG (Attachment missing)

Kunda1

2017-01-28 12:20

administrator  

transparency-fine-fc-0.16.PNG (Attachment missing)

Kunda1

2017-01-28 12:22

administrator   ~0008050

Multiple confirmations in the forum thread

Related Changesets

FreeCAD: master d7ed8c43

2017-02-10 23:53:57

yorik

Details Diff
Part: Set per-face transparency in boolean ops - fixes 0001029,0002806 Affected Issues
0001029, 0002806
mod - src/Mod/Part/Gui/ViewProvider.cpp Diff File
mod - src/Mod/Part/Gui/ViewProvider.h Diff File
mod - src/Mod/Part/Gui/ViewProviderBoolean.cpp Diff File

Issue History

Date Modified Username Field Change
2016-12-02 13:54 easyw-fc New Issue
2016-12-05 14:12 easyw-fc Tag Attached: Part
2017-01-28 12:20 Kunda1 File Added: transparency-prob-fc-0.17.PNG
2017-01-28 12:20 Kunda1 File Added: transparency-fine-fc-0.16.PNG
2017-01-28 12:22 Kunda1 Note Added: 0008050
2017-01-28 12:22 Kunda1 Status new => confirmed
2017-02-10 04:59 Kunda1 Tag Attached: transparency
2017-02-10 05:06 Kunda1 Relationship added related to 0001029
2017-02-10 05:06 Kunda1 Relationship added related to 0000848
2017-02-10 05:09 Kunda1 Relationship added related to 0001626
2017-02-10 23:08 yorik Relationship replaced duplicate of 0001029
2017-02-10 23:54 yorik Changeset attached => FreeCAD Master master d7ed8c43
2017-02-10 23:54 yorik Assigned To => yorik
2017-02-10 23:54 yorik Status confirmed => closed
2017-02-10 23:54 yorik Resolution open => fixed