View Issue Details

IDProjectCategoryView StatusLast Update
0002783FreeCADBugpublic2016-11-19 12:50
Reporteralllexandrrr Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformi686 32 bitOSROSA LINUXOS Version3.10.51
Product Version0.17 
Summary0002783: Build error message
DescriptionWhen I do a project build error message is displayed:

[ 93%] Building CXX object src/Mod/TechDraw/Gui/CMakeFiles/TechDrawGui.dir/AppTechDrawGuiPy.cpp.o
/src/FreeCAD/src/Mod/PartDesign/Gui/Command.cpp: In lambda function:

/src/FreeCAD/src/Mod/PartDesign/Gui/Command.cpp:1891:68: error: «this» was not captured for this lambda function
In file included from /src/include/boost/filesystem/path_traits.hpp:23:0,
                 from /src/include/boost/filesystem/path.hpp:25,
                 from /src/FreeCAD/src/App/PropertyStandard.h:34,
                 from /src/FreeCAD/src/App/DocumentObject.h:28,
                 from /src/FreeCAD/src/App/GeoFeature.h:27,
                 from /src/FreeCAD/src/App/FeaturePython.h:30,
                 from /src/FreeCAD/src/App/DocumentObjectGroup.h:27,
                 from /src/FreeCAD/src/Mod/PartDesign/Gui/Command.cpp:37:
/src/include/boost/system/error_code.hpp: At global scope:
Steps To Reproducemake build
TagsNo tags attached.
FreeCAD Information

Relationships

duplicate of 0002782 closedwmayer Build error message 
child of 0002784 closed The patch is to build the current version 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2016-11-19 09:09 alllexandrrr New Issue
2016-11-19 12:49 wmayer Relationship added duplicate of 0002782
2016-11-19 12:49 wmayer Status new => closed
2016-11-19 12:49 wmayer Resolution open => duplicate
2016-11-19 12:50 wmayer Relationship added child of 0002784