View Issue Details

IDProjectCategoryView StatusLast Update
0002696DraftBugpublic2016-10-06 14:24
Reporterrhorton Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
OSwindowsOS Version10 
Product Version0.16 
Summary0002696: DWire entry issue
DescriptionWhen using the DWire entry tool to add a new DWire, I found that entering a "-" symbol to enter a negative number made the right hand side indicator turn to a red cross, before a number was entered, whereupon it went green again. This was OK, BUT: when it went red, the previously entered point was deleted from the drawing.
Steps To ReproduceOpen a new file. Select Draft toolset.
Orient the display so you can see the 2d grid on the XY plane.
From Create Objects, select DWire. The DWire entry system displays.
Make Relative and Filled checked.
Enter a first value of 0,0,0 and click "Enter point"
Enter a second value of 50,0,0 and click "Enter point". You should see a horizontal line on the grid.
Enter a third value of 0,10,0 and click "Enter point". You should see a vertical line on the right of the horizontal line.

Now, enter a fourth value of -40,0,0 and click "Enter point". Expected behaviour would be a new line moving left from the top of the second line. What actually happens is when you type the "-" key in the x box, the indicator turns red and the second line is deleted.
TagsNo tags attached.
FreeCAD Information

Activities

yorik

2016-09-14 22:37

administrator   ~0007321

Indeed something strange happening... I'll investigate

yorik

2016-10-06 14:23

administrator   ~0007344

The problem was that the built-in Ctrl+Z "undo" shortcut was apparently triggered by the "-" input, no idea why. Anyway, I now removed that Ctrl+Z shortcut entirely, since the underlined shortcut that appears on the undo button works perfectly.

Related Changesets

FreeCAD: master 7ef31e49

2016-10-06 16:23:54

yorik

Details Diff
Draft: Disabled builtin ctrl+z shortcut in wire drawing (indicated UI shortcut works) - fixed 0002696 Affected Issues
0002696
mod - src/Mod/Draft/DraftGui.py Diff File

Issue History

Date Modified Username Field Change
2016-09-14 18:46 rhorton New Issue
2016-09-14 22:37 yorik Note Added: 0007321
2016-09-14 22:37 yorik Assigned To => yorik
2016-09-14 22:37 yorik Status new => assigned
2016-10-06 14:23 yorik Note Added: 0007344
2016-10-06 14:24 yorik Changeset attached => FreeCAD Master master 7ef31e49
2016-10-06 14:24 yorik Status assigned => closed
2016-10-06 14:24 yorik Resolution open => fixed