View Issue Details

IDProjectCategoryView StatusLast Update
0002551PathBugpublic2016-05-31 15:51
Reportersliptonic Assigned Tosliptonic  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformPCOSDebian 
Product Version0.16 
Fixed in Version0.17 
Summary0002551: Pocket segfaults on tool change
DescriptionIssue imported from https://github.com/yorikvanhavre/FreeCAD/issues/17

 sliptonic commented on 22 Dec 2014

Created a pathpocket for a padded sketch (see test file linked below)

Open the compound, select the path and change the tool to '2'. Hit enter. After several seconds, FreeCAD will segfault.

This doesn't happen with all tool diameters.

https://dl.dropboxusercontent.com/u/9245675/pockettest.fcstd
TagsNo tags attached.
FreeCAD Information

Activities

yorik

2016-05-13 21:59

administrator  

pockettest.fcstd (12,234 bytes)

yorik

2016-05-13 21:59

administrator   ~0007098

yorikvanhavre commented on 29 Dec 2014

I don't get a crash, but the diameter is not correctly taken from the host project, needs to be fixed anyway.

sliptonic

2016-05-31 15:50

developer   ~0007132

Can't reproduce the error with improved Path.

sliptonic

2016-05-31 15:51

developer   ~0007133

The pathimprove changes affect how operations get the tool diameter. This problem no longer exists.

Issue History

Date Modified Username Field Change
2016-05-13 21:59 yorik New Issue
2016-05-13 21:59 yorik File Added: pockettest.fcstd
2016-05-13 21:59 yorik Note Added: 0007098
2016-05-13 22:00 yorik Reporter yorik => sliptonic
2016-05-31 15:50 sliptonic Note Added: 0007132
2016-05-31 15:51 sliptonic Note Added: 0007133
2016-05-31 15:51 sliptonic Status new => closed
2016-05-31 15:51 sliptonic Assigned To => sliptonic
2016-05-31 15:51 sliptonic Resolution open => fixed
2016-05-31 15:51 sliptonic Fixed in Version => 0.17