View Issue Details

IDProjectCategoryView StatusLast Update
0002253File formatsFeaturepublic2015-09-10 19:13
Reportersavio araujo Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Summary0002253: add support for Rhino3D files
Descriptionavailable library from developers of Rhino3D (http://opennurbs.org/). it should be nice to have capability to load/save Rhino3D models, together with https://sourceforge.net/projects/libnurbs/ it should be good replacement for Rhino3D in linux
TagsNo tags attached.
FreeCAD Information

Relationships

duplicate of 0000337 acknowledged File formats add support for Rhino3D files 
related to 0000895 closedwmayer FreeCAD Part.BSplineCurve: allow to set degree and mutliplicites when calling constructor. 

Activities

Jriegel

2011-05-17 07:35

administrator   ~0006359

Actually I dont like myself to struggle with commercial file formats. But If someone have coding time - be welcome.

normandc

2011-05-21 11:51

manager   ~0006360

It is unclear to me reading the OpenNURBS Initiative website whether the 3DM file format is open source or commercial. But it seems to be completely documented, which I think means it would be much less of a struggle to incorporate in FreeCAD as other proprietary and closed formats. It would indeed be really nice to have a CAD program on Linux able to open 3DM files. But there is no NURBS support or tools in FreeCAD at the moment, maybe Blender (which supports NURBS surfaces) would be best suited?

Jriegel

2011-05-22 18:25

administrator   ~0006361

OCC support NURBS, but we lack the tools to model it.
So we could do boolean operation on loaded NURBS, buts
thats around it.

Actually I'm not a big fan of NURBS. IMO subdevision surfaces are
the way of the future...

yorik

2011-05-29 13:54

administrator   ~0006362

Actually since freecad supports nurbs, 3DM format should be possible to handle without problems (and IIRC Rhino also supports brep-like objects)... On the openNurbs website there is a C++ toolkit which can read/write 3DM files, and appears to be compatible with GPL license ( http://www.opennurbs.org/docs.htm ):

"Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software."

I'm downloadiing the toolkit right now to have a look...

yorik

2011-05-29 13:59

administrator   ~0006363

Interesting quotes from the FAQ included inside the toolkit:

"Excellent compilers and make utilities are available from
The Free Software Foundation <http://www.fsf.org> You have
the option of using these tools free of charge."

"Internally, Rhino stores all surfaces as some type of b-rep and the
openNURBS toolkit reads these objects as b-reps."

yorik

2011-05-29 14:04

administrator   ~0006364

Hm reading a file looks actually pretty simple, if we can include the opennurbs code!

unauthenticated

2011-06-01 14:30

viewer   ~0006365

Reading the file should not be the problem.
You have to transfer each entity to a OCC object.
Not only the NURBS, also the trimming curves and all
other entities like planes and so on...

Its posible, but a lot of work an tuning to get it run....

keithsloan52

2014-08-02 23:06

developer   ~0006366

I have a skeleton FreeCAD importer that is using the OpenNurbs library to parse a 3dm file. I will now try and add code to create nurbs etc

yorik

2015-09-10 19:08

administrator   ~0006382

Why are you cloning all these issues?

yorik

2015-09-10 19:13

administrator   ~0006384

Please do not clone issues like that without a reason... It won't make them fixed magically, and only gives us more work. Thanks

Issue History

Date Modified Username Field Change
2015-09-09 22:02 savio araujo New Issue
2015-09-09 22:02 savio araujo Issue generated from: 0000337
2015-09-10 19:08 yorik Note Added: 0006382
2015-09-10 19:13 yorik Relationship added duplicate of 0000337
2015-09-10 19:13 yorik Note Added: 0006384
2015-09-10 19:13 yorik Status acknowledged => closed
2015-09-10 19:13 yorik Assigned To => yorik
2015-09-10 19:13 yorik Resolution open => duplicate