View Issue Details

IDProjectCategoryView StatusLast Update
0002242PathBugpublic2017-02-15 06:18
Reporterjonnor Assigned Tokkremitzki  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Summary0002242: Path: Offset profile of circle(s) causes exceptions
DescriptionCouple of issues experienced when trying to mill out a part with circles.

Selecting a single circle edge (or face) and using the libarea/offset profile,
I get an exception. There is a different exception if I select multiple. All seem related to expectations that there be multiple edges and/or vertices.

See attached example project for real-life example.
Steps To Reproduce* Open new document
* Add some circular geometry (example: Sketch with circle)
* Select one or more circle edge
* Invoke Path Profile using libarea
Additional InformationTested on git master, commit 3c10cd1af2bb702953f3cff8fdb3c6e6df1bd7b5

Selecting a circular face (like top of cylinder), and using the (non-offset) Profile seems to work. But there are several cases where such a face is not existant. For instance when a part has circular hole(s) in it (with size is larger than tool size so cannot drill).
--

When selecting a single edge:

Traceback (most recent call last):
  File "/home/jon/contrib/code/freecad/Mod/Path/PathScripts/PathKurve.py", line 145, in execute
    self.final_depth,self.use_CRC,obj.Direction,self.startpt,self.endpt)
  File "/home/jon/contrib/code/freecad/Mod/Path/PathScripts/PathKurveUtils.py", line 249, in makePath
    curve = makeAreaCurve(edges,direction,startpt, endpt)
  File "/home/jon/contrib/code/freecad/Mod/Path/PathScripts/PathKurveUtils.py", line 57, in makeAreaCurve
    vlist,edgestart,common = PathSelection.Sort2Edges([cleanededges[0],cleanededges[1]])
<type 'exceptions.IndexError'>: list index out of range
Profile: list index out of range

When selecting multiple edges:

'NoneType' object is not iterableRunning the Python command 'Path_Profile' failed:
Traceback (most recent call last):
  File "/home/jon/contrib/code/freecad/Mod/Path/PathScripts/PathProfile.py", line 213, in Activated
    selection = PathSelection.multiSelect()
  File "/home/jon/contrib/code/freecad/Mod/Path/PathScripts/PathSelection.py", line 203, in multiSelect
    vlist,edgestart,edgecommon=Sort2Edges(edgelist)
  File "/home/jon/contrib/code/freecad/Mod/Path/PathScripts/PathSelection.py", line 51, in Sort2Edges
    a1 = e0.Vertexes[1]

list index out of range

TagsNo tags attached.
FreeCAD Information

Activities

jonnor

2015-09-08 20:05

reporter  

baseclamp-cnc.fcstd (31,304 bytes)

Kunda1

2017-01-23 21:26

administrator   ~0007926

OP please retest on 0.16
Also as an FYI when you post ticket in the future please add the contents of Help > About FreeCAD > Copy to clipboard

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=10&t=20163

sliptonic

2017-01-31 23:03

manager   ~0008139

Can't replicate the exception. I get some bogus paths depending on settings but that's a broader problem we're fighting in a number of areas unrelated to this issue.

Unless OP weighs in, recommend close.

Kunda1

2017-02-02 13:07

administrator   ~0008168

In that case, I'm resolving issue (that way OP can still re-open).
Thanks @sliptonic

Issue History

Date Modified Username Field Change
2015-09-08 20:05 jonnor New Issue
2015-09-08 20:05 jonnor File Added: baseclamp-cnc.fcstd
2017-01-23 21:26 Kunda1 Note Added: 0007926
2017-01-23 21:26 Kunda1 Status new => feedback
2017-01-23 21:26 Kunda1 Tag Attached: #pending
2017-01-31 13:13 Kunda1 Project FreeCAD => Path
2017-01-31 23:03 sliptonic Note Added: 0008139
2017-02-02 13:07 Kunda1 Note Added: 0008168
2017-02-02 13:07 Kunda1 Status feedback => resolved
2017-02-02 13:07 Kunda1 Resolution open => unable to reproduce
2017-02-02 13:07 Kunda1 Assigned To => Kunda1
2017-02-02 13:07 Kunda1 Assigned To Kunda1 =>
2017-02-02 13:07 Kunda1 Tag Detached: #pending
2017-02-15 06:17 kkremitzki Status resolved => closed
2017-02-15 06:18 kkremitzki Assigned To => kkremitzki