View Issue Details

IDProjectCategoryView StatusLast Update
0000222FreeCADBugpublic2010-12-31 12:04
Reporterpperisin Assigned To 
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
Product Version0.11 
Summary0000222: Union of Box and Torus
Description
Create a box
Crate Torus
Try to union them.

Additional InformationWin7 32bit
latest unstable build (3797)
TagsNo tags attached.
FreeCAD Information

Relationships

duplicate of 0000177 closed [Part] Boolean operation fail with complex shapes 

Activities

wmayer

2010-12-21 10:54

administrator   ~0000465

This is a bug or limitation of the OpenCascade CAD kernel. There are many known problems with boolean operations with certain shapes.

pperisin

2010-12-28 14:32

reporter   ~0000475

Last edited: 2010-12-28 14:33

Just to report - I have tested this with NaroCAD, and it seems to work. Union and cut with Box, Torus and sphere worked fine. NaroCAD works with Open CasCade too.

wmayer

2010-12-28 15:59

administrator   ~0000476

In OCC for many things there are two or more algorithms available to do certain tasks. Especially, for boolean operations there is a second algorithms which apparently is even faster but not very accurate. Maybe the NaroCAD guys used this alternative. I have to check...

Many thanks for the hint!

wmayer

2010-12-30 11:26

administrator   ~0000477

I got the difference. The point is that we always delete the internal triangulation of a shape after displaying it to free some memory and keep exported brep files files rather slim. However, for certain shapes such as torus this has some drawbacks like the not properly working boolean operations.

wmayer

2010-12-31 12:04

administrator   ~0000479

Fixed in 3842. To solve the issue all occurrences of BRepTools::Clean have been removed since this causes the problems for BOP of torus.

Issue History

Date Modified Username Field Change
2010-12-21 09:32 pperisin New Issue
2010-12-21 10:52 wmayer Relationship added duplicate of 0000177
2010-12-21 10:54 wmayer Note Added: 0000465
2010-12-28 14:32 pperisin Note Added: 0000475
2010-12-28 14:33 pperisin Note Edited: 0000475
2010-12-28 15:59 wmayer Note Added: 0000476
2010-12-30 11:26 wmayer Note Added: 0000477
2010-12-31 12:04 wmayer Note Added: 0000479
2010-12-31 12:04 wmayer Status new => closed
2010-12-31 12:04 wmayer Resolution open => fixed