View Issue Details

IDProjectCategoryView StatusLast Update
0002064DrawingBugpublic2015-12-15 13:18
Reportertriplus Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntu 
Fixed in Version0.16 
Summary0002064: Editable text changes in drawing template not restored.
DescriptionI am not sure if this is related and therefore i decided to open new bug report:

http://www.freecadweb.org/tracker/view.php?id=1963

I was testing editable text in drawing workbench and noticed changes don't persist? I am quite sure this used to work in the past and the changes persisted.

I looked inside the .fcstd file and noticed actual change is saved. I am guessing at load time instead of loading SVG from inside the .fcstd file default drawing template with the same name is used instead?
Steps To Reproduce- Insert default drawing template.
- In Property View make some changes to editable text.
- Save the file and close FreeCAD.
- Reopen the file and check if text was saved or defaults are loaded again.
TagsNo tags attached.

Relationships

related to 0001963 closedwmayer FreeCAD Only write needed user data in FCSTD file if any. 

Activities

ian.rees

2015-04-24 23:07

developer   ~0006085

I've confirmed this bug, it is caused by commit 8476bab - will look into a fix.

ian.rees

2015-04-25 01:12

developer   ~0006086

The issue here is that the Template path Property is changed by FeaturePage::onDocumentRestored(), which triggers FeaturePage::onChanged() to get the editable text values again from the template. The old check for !isRestoring() in FeaturePage::onChanged() doesn't work as intended, because by the point that onDocumentRestored() is called, isRestoring() returns false.

I'm not sure what the best fix for this is, because it's hard to tell the difference between loading a document and changing a template, from the perspective of FeaturePage::onChanged. What would be ideal is if the functionality in FeaturePageonDocumentRestored() could be triggered just before document restore has been completed.

A possible fix is at https://github.com/ianrrees/FreeCAD_tinkering/tree/fix2064 , though that might not be the ideal solution when changing templates... -Ian-

Related Changesets

FreeCAD: master 74c912f1

2015-05-02 13:14:38

wmayer

Details Diff
+ fixes 0002064: Editable text changes in drawing template not restored. Affected Issues
0002064
mod - src/Mod/Drawing/App/FeaturePage.cpp Diff File

Issue History

Date Modified Username Field Change
2015-04-20 23:54 triplus New Issue
2015-04-24 23:07 ian.rees Note Added: 0006085
2015-04-24 23:08 ian.rees Assigned To => ian.rees
2015-04-24 23:08 ian.rees Status new => assigned
2015-04-25 00:12 ian.rees Relationship added related to 0001963
2015-04-25 01:12 ian.rees Note Added: 0006086
2015-05-02 11:16 wmayer Summary Editable text changes in drawing template not saved. => Editable text changes in drawing template not restored.
2015-05-02 11:21 wmayer Changeset attached => FreeCAD Master master 74c912f1
2015-05-02 11:21 wmayer Assigned To ian.rees => wmayer
2015-05-02 11:21 wmayer Status assigned => closed
2015-05-02 11:21 wmayer Resolution open => fixed
2015-12-15 13:18 yorik Fixed in Version => 0.16