View Issue Details

IDProjectCategoryView StatusLast Update
0002021FreeCADBugpublic2015-03-23 14:46
ReporterRob_K Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformMacOSOSX 
Product Version0.14 
Fixed in Version0.15 
Summary0002021: Offset in
DescriptionBuilding a model, when going to draft mode to draw on a plane, the offset feature does not work.



Select Draft Workbench

left click on Set/Unset a working plane button just right of the Measure Distance button

Type in offset mode e.g. 110 mm

Hit Enter key

Select one of the five buttons below e.g. XY

The expected result is to produce the XY plane 110 mm up the Z axis. This is not the case on Mac OSX. When typing into the Offset box, the green tick mark is constantly there so there is no indication that the offset value has been successfully input and pressing enter has no effect. Once the XY button is clicked an XY grid is displayed with the center at the Origin, not at
X = 0
Y = 0
Z = 110
as expected. Any shapes drawn also appear at Z = 0 and the offset value has to be manually typed in and all calculations do not have the offset benefit.

Steps To ReproduceAfter building a simple 3D part,
Select Draft Workbench.
left click on Set/Unset a working plane button just right of the Measure Distance button.
Type in offset mode e.g. 110 mm.
Hit Enter key.
Select one of the five buttons below e.g. XY.

The expected result is to produce the XY plane 110 mm along the Z axis. On Mac OSX Mavericks, this does not function as expected. When typing into the Offset box, the green tick mark is constantly there so there is no indication that the offset value has been successfully input and pressing enter has no effect and the cursor remains flashing in the same place. Once the XY button is clicked an XY grid is displayed with the center at the Origin, not at
X = 0
Y = 0
Z = 110
as expected. Any shapes drawn also appear at Z = 0 and the offset value has to be manually typed in and all calculations do not have the offset benefit.

The issue is constantly reproduced, closing and re-opening the project and also closing and re-opening FreeCAD does not alter the behavior.
TagsNo tags attached.
FreeCAD Information

Relationships

duplicate of 0001621 closedyorik Draft "Offset" option in "Set/unset a working plane" didn't work 

Activities

yorik

2015-03-23 14:45

administrator   ~0005930

This is fixed by 0001621 in v0.15.

yorik

2015-03-23 14:46

administrator   ~0005931

Closing this now because it's already fixed... Please reopen if needed

Issue History

Date Modified Username Field Change
2015-03-22 21:21 Rob_K New Issue
2015-03-23 14:44 yorik Relationship added duplicate of 0001621
2015-03-23 14:45 yorik Note Added: 0005930
2015-03-23 14:46 yorik Note Added: 0005931
2015-03-23 14:46 yorik Status new => closed
2015-03-23 14:46 yorik Assigned To => yorik
2015-03-23 14:46 yorik Resolution open => duplicate
2015-03-23 14:46 yorik Fixed in Version => 0.15