View Issue Details

IDProjectCategoryView StatusLast Update
0001970FreeCADBugpublic2015-03-23 13:53
Reporterektus Assigned Towmayer  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
OSWindows 7 professional 
Summary0001970: Spaceball 5000 USB no longer works in Windows 7 in 0.15 dev versions
DescriptionIn 0.14.3700, my Spaceball 5000 USB device is working. In the current 0.15.4346 the license and config tabs are there, but no function of either the USB spaceball nor the serial SpaceMouse.


Regards
Ektus.

OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.4346 (Git)
Branch: master
Hash: e329cb5c3acd5b170359e0e8cd28d98b61be935d
Python version: 2.7.8
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.1
Steps To ReproduceStart 0.14.3700 or older version. Use Space Mouse successfully.
Start any 0.15 version at least up to 4572. Space Mouse is without function, albeit the config page being accessible.

OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.4572 (Git)
Branch: master
Hash: be2bb52796ae1be001882da114e8272c4c746af0
Python version: 2.7.8
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.1
Additional InformationDiscussion in the forum at http://forum.freecadweb.org/viewtopic.php?f=4&t=9198
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0001959 closedwmayer 3DConnexion 3D mouse not detected 
related to 0002019 closedwmayer SpaceNav control active without application focus 

Activities

ektus

2015-03-02 20:02

reporter   ~0005850

no change in latest build
OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.4630 (Git)
Branch: master
Hash: 1b7c0e2a51bf4bffe5f345204c9c2bc6681e151d
Python version: 2.7.8
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.1

wmayer

2015-03-03 09:46

administrator   ~0005851

Could you post the full version information of your 0.14.3700? Maybe the problem is not in FreeCAD but in one of the 3rd party libraries.

ektus

2015-03-03 17:20

reporter   ~0005852

It's working in all available versions. Windows installer from Sourceforge, both 32 and 64 bit, see below.

OS: Windows 7
Platform: 32-bit
Version: 0.14.3389
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1

OS: Windows 7
Word size: 64-bit
Version: 0.14.3700 (Git)
Branch: releases/FreeCAD-0-14
Hash: 32f5aae0a64333ec8d5d160dbc46e690510c8fe1
Python version: 2.7.6
Qt version: 4.8.5
Coin version: 4.0.0a
SoQt version: 1.6.0a
OCC version: 6.6.0


OS: Windows 7
Word size: 32-bit
Version: 0.14.3700 (Git)
Branch: releases/FreeCAD-0-14
Hash: 32f5aae0a64333ec8d5d160dbc46e690510c8fe1
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.5.1

peterl94

2015-03-06 06:42

developer   ~0005854

wmayer, do you think something changed in Qt 4.8.6 that would cause this problem? Does the libpack 9 have Qt 4.8.5?

Also, I'm assuming as long as FREECAD_USE_3DCONNEXION is on everything should just work, or do I need to do something else?

wmayer

2015-03-06 09:02

administrator   ~0005855

> wmayer, do you think something changed in Qt 4.8.6 that would cause this problem?
Yes, I thought about this. But apparently this isn't the problem.
> Does the libpack 9 have Qt 4.8.5?
Yes.
> or do I need to do something else?
No, setting FREECAD_USE_3DCONNEXION should be sufficient to make it work.

So, another candidate could be the new Quarter-based viewer. But the weird thing is that under Linux it apparently works.

So, I run out of ideas what else can be wrong and since I don't have a space mouse there is nothing I can do. In order to get this fixed we need a volunteer with a space mouse to make a debug build on Windows and step through the code.

Related Changesets

FreeCAD: master f2d8fc91

2015-02-21 18:46:06

wmayer

Details Diff
+ issue 0001970: Spaceball 5000 USB no longer works in Windows 7 in 0.15 dev versions Affected Issues
0001970
mod - src/Gui/GuiApplicationNativeEventAware.cpp Diff File

FreeCAD: master 4a5a4e9a

2015-03-11 12:44:38

wmayer

Details Diff
+ fixes 0001970: Spaceball 5000 USB no longer works in Windows 7 in 0.15 dev versions Affected Issues
0001970
mod - src/Gui/Quarter/QuarterWidgetP.cpp Diff File

Issue History

Date Modified Username Field Change
2015-02-16 19:47 ektus New Issue
2015-02-16 20:54 wmayer Relationship added related to 0001959
2015-02-21 18:09 wmayer Changeset attached => FreeCAD Master master f2d8fc91
2015-03-02 20:02 ektus Note Added: 0005850
2015-03-03 09:46 wmayer Note Added: 0005851
2015-03-03 17:20 ektus Note Added: 0005852
2015-03-06 06:42 peterl94 Note Added: 0005854
2015-03-06 09:02 wmayer Note Added: 0005855
2015-03-11 11:58 wmayer Changeset attached => FreeCAD Master master 4a5a4e9a
2015-03-11 11:58 wmayer Assigned To => wmayer
2015-03-11 11:58 wmayer Status new => closed
2015-03-11 11:58 wmayer Resolution open => fixed
2015-03-23 13:53 tanderson69 Relationship added related to 0002019