View Issue Details

IDProjectCategoryView StatusLast Update
0001910DrawingFeaturepublic2017-02-03 12:56
Reporterulrich1a Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionwon't fix 
Product Version0.14 
Summary0001910: Add a preference page for the Drawing workbench and allow to select a folder for custom templates
DescriptionThe Drawing workbench has no way to add custom templates without copy them into the FreeCAD installation path. This is not allowed on some operation systems. There is a need to add custom templates in a customizable user directory.

So users can have templates with the company logo for example. For practical reasons there could be also a ticker to only show custom templates.
TagsNo tags attached.

Relationships

related to 0001963 closedwmayer FreeCAD Only write needed user data in FCSTD file if any. 

Activities

triplus

2015-01-11 20:10

developer   ~0005616

Last edited: 2017-01-19 13:04

View 2 revisions

Workaround i used for this issue in the past: I added macro buttons (for each desired page size one) that created new page and inserted drawing template located in my home folder. But as situation improved:

0001856

And custom drawing template file name can now be used and the template is shown in drop down menu i moved my drawing templates to system wide drawing template location.

I agree it would be nice to have option to put custom templates somewhere in home folder in the future.

yorik

2015-04-20 15:19

administrator   ~0006062

This is caused by 0001963 ...

Kunda1

2017-01-19 13:06

administrator   ~0007875

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=10&t=20049

ian.rees

2017-02-03 05:58

developer   ~0008186

Does not apply to TechDraw, which:
  * Gives a nice button, the second in the toolbar in fact, for picking a template from an arbitrary directory.
  * Already has a preferences page including both "Default Template" and "Template Directory"

normandc

2017-02-03 06:33

manager   ~0008187

I think this could be closed as "won't fix".

ian.rees

2017-02-03 06:34

developer   ~0008188

Me too, let's ask Kunda1 to do it :).

Kunda1

2017-02-03 12:55

administrator   ~0008192

Since it exists in TechDraw WB
+ there is a workaround 0001910:0005616 for those who do wish to still use Drawing WB (BTW, Drawing WB will be deprecated after 0.17)
+ my generous colleagues have given the 'green light, closing this ticket as "won't fix".
Done ;)

Issue History

Date Modified Username Field Change
2015-01-11 12:08 ulrich1a New Issue
2015-01-11 20:10 triplus Note Added: 0005616
2015-04-20 15:19 yorik Relationship added related to 0001963
2015-04-20 15:19 yorik Note Added: 0006062
2017-01-19 13:04 Kunda1 Note Edited: 0005616 View Revisions
2017-01-19 13:06 Kunda1 Note Added: 0007875
2017-02-02 21:40 Kunda1 Project FreeCAD => Drawing
2017-02-03 05:58 ian.rees Note Added: 0008186
2017-02-03 06:33 normandc Note Added: 0008187
2017-02-03 06:34 ian.rees Note Added: 0008188
2017-02-03 12:55 Kunda1 Note Added: 0008192
2017-02-03 12:55 Kunda1 Status new => closed
2017-02-03 12:56 Kunda1 Resolution open => won't fix