View Issue Details

IDProjectCategoryView StatusLast Update
0001791FreeCADBugpublic2015-01-12 00:10
Reporterlens42 Assigned Towmayer  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSOSX 
Product Version0.14 
Summary0001791: Counterbores do not follow when hole is moved
DescriptionWhen making a hole through a solid with counterbores on both sides, when later moving the hole, one of the counterbores will not follow. Please refer to this forum post:

http://forum.freecadweb.org/viewtopic.php?f=3&t=8074

Steps To Reproduce1) Make a sketch with 20x20mm square with a 10mm diam circle inside
2) Pad #1 out 20mm to make cube with a 10mm hole
3) Make a new sketch on same plane as #1 with a 12mm diam circle with the center coincident with the hole from #1. To align the circles, use the icon with the blue dashed line above a blue box ("create an edge link to an external geometry") to highlight the existing hole edge and it's centerpoint. Then use the coincident tool to line up the centerpoint of the new circle with the centerpoint of the existing hole.
4) pocket 0000003 circle 4mm deep so now there is a 4mm deep counterbore (shoulder) concentric with the hole
5) Flip the cube over and do the same thing as 0000003, but on a new sketch on the opposite side.
6) Go back to sketch 1 and move the original hole. The 2nd counterbore will not follow and is now offset.
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0001339 closedwmayer Crash when giving sketch with external geometry a new support (face) after the original support was deleted 

Activities

lens42

2014-10-20 17:03

reporter  

counterboretest_aftermove.FCStd (Attachment missing)

wmayer

2015-01-06 15:50

administrator   ~0005541

https://github.com/FreeCAD/FreeCAD_sf_master/commit/e7b44d28663279f4a813d0fef94d8c149af24bb0

normandc

2015-01-11 21:20

manager   ~0005618

This bug means that the Sketcher External Geometry tool is basically useless since even a minute change in an upstream sketch or feature deletes all external geometry from the following sketches.

Related Changesets

FreeCAD: master e16305cb

2015-01-12 00:55:56

wmayer

Details Diff
+ fixes 0001791: Counterbores do not follow when hole is moved Affected Issues
0001791
mod - src/Mod/Sketcher/App/SketchObject.cpp Diff File

Issue History

Date Modified Username Field Change
2014-10-20 17:03 lens42 New Issue
2014-10-20 17:03 lens42 File Added: counterboretest_aftermove.FCStd
2015-01-06 15:50 wmayer Note Added: 0005541
2015-01-06 16:25 shoogen Relationship added related to 0001339
2015-01-11 21:20 normandc Note Added: 0005618
2015-01-12 00:10 wmayer Changeset attached => FreeCAD Master master e16305cb
2015-01-12 00:10 wmayer Assigned To => wmayer
2015-01-12 00:10 wmayer Status new => closed
2015-01-12 00:10 wmayer Resolution open => fixed