View Issue Details

IDProjectCategoryView StatusLast Update
0001540DrawingBugpublic2014-08-08 01:39
ReporterLambdaTheUltimate Assigned Toyorik  
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
OSWin 
Product Versiontrunk 
Target Version0.15Fixed in Version0.15 
Summary0001540: Drawing / Editable Texts / not updating - just needs App.ActiveDocument.recompute()
DescriptionVersion 0.13 and 0.14 changing the 'Editable Texts' does not update the Drawing

Just needs a;

  App.ActiveDocument.recompute()

Trivial: but new users (non-Python programmers) won't be able to do that - until users discover 'F5 Refresh' key shortcut, they would be frustrated.
Steps To Reproduce(a) Select a Drawing Page, select 'Data' tab, modify 'Editable Texts' property (by clicking ... button), click OK

(b) Move to another property to trigger an update (an action needed often with many other properties)

(c) Drawing does 'not' update (confusing for new users)

(d) To resolve, paste command in Python console;

  App.ActiveDocument.recompute()

(e) Drawing text appears
Additional InformationPS Issue 547 is original Feature request - but I had no clue how to link this report
TagsNo tags attached.

Relationships

related to 0000547 closedyorik FreeCAD Drawing module - editable title blocks 

Activities

yorik

2014-05-11 20:10

administrator   ~0004656

Not sure this is not the intended way... Normally, changing a property doesn't update the document, but you can see an update is required because the update button lightens... Only in certain cases changing a property triggers an updates immediately.

But in this case it might be a good thing indeed...

Related Changesets

FreeCAD: master dc3ebfb5

2014-08-07 15:39:33

yorik

Details Diff
Fix in Drawing page object - fixes 0001540
* Changing the editable texts updates the page automatically
* Added a doc.recompute() after creating a new page
Affected Issues
0001540
mod - src/Mod/Drawing/App/FeaturePage.cpp Diff File
mod - src/Mod/Drawing/Gui/Command.cpp Diff File

Issue History

Date Modified Username Field Change
2014-05-11 17:07 LambdaTheUltimate New Issue
2014-05-11 18:31 shoogen Relationship added related to 0000547
2014-05-11 18:31 shoogen Relationship deleted related to 0000547
2014-05-11 20:04 yorik Relationship added related to 0000547
2014-05-11 20:10 yorik Note Added: 0004656
2014-05-11 20:10 yorik Assigned To => yorik
2014-05-11 20:10 yorik Status new => assigned
2014-05-11 20:10 yorik Project FreeCAD => Drawing
2014-07-06 15:27 yorik Target Version => 0.15
2014-08-07 14:12 yorik Changeset attached => FreeCAD Master master dc3ebfb5
2014-08-07 14:12 yorik Status assigned => closed
2014-08-07 14:12 yorik Resolution open => fixed
2014-08-08 01:39 yorik Fixed in Version => 0.15