View Issue Details

IDProjectCategoryView StatusLast Update
0001421FreeCADBugpublic2014-10-14 18:21
Reporterherman15 Assigned Toshoogen  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformX86_64OSLinux Mint 
Product Versiontrunk 
Summary0001421: STEP import failure due to non-ASCII chars path
DescriptionImporting a specific STEP (appended) file causes the following error

Traceback (most recent call last):
  File "<string>", line 1, in <module>
<type 'exceptions.Exception'>: OSD_Path::OSD_Path : Invalid dependent name

This STEP file is a heatsink provided by Fischer Elektronik. Other STEP files from this distributor behave identically

But this STEP file could be opened and modified by other standard CAD software (CATIA, ZW3D)

Steps To ReproduceJust open STEP file
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0001411 closedshoogen Importing and Exporting fails on Windows due to filepath encoding 
parent of 0001763 closedshoogen use UTF8 for filenames 
child of 0000812 closedshoogen Does not import files with the national chars in the file name. 

Activities

shoogen

2014-02-19 10:20

developer   ~0004239

('ZWCAD Software Co.'),'Version 1.0','ZW3D to STEP translator'
I can't reproduce the problem in the Part Workbench. (using debian wheezy)

Can you please try to open the file from a path only containing ASCII characters.

herman15

2014-02-19 10:32

reporter   ~0004240

Thanks for your fast response

The problem was the non ASCII characters "äöü" in the Path name of the STEP file

wmayer

2014-03-07 09:36

administrator   ~0004390

As long as OCC doesn't support unicode the change below uses the local 8-bit encoding so that depending on the region e.g. umlauts or other characters outside 7-bit ASCII is supported.

https://github.com/FreeCAD/FreeCAD_sf_master/commit/040c19b1c1618043631e45c74ddd30536cf09252

shoogen

2014-09-24 11:33

developer   ~0005150

Unicode support is scheduled for OCCT 6.8.0

Related Changesets

FreeCAD: master 040c19b1

2014-03-06 16:35:33

wmayer

Details Diff
+ relates to 0001421 Affected Issues
0001421, 0001747
mod - src/Mod/Import/App/AppImportPy.cpp Diff File
mod - src/Mod/Import/Gui/AppImportGuiPy.cpp Diff File
mod - src/Mod/Part/App/TopoShape.cpp Diff File

Issue History

Date Modified Username Field Change
2014-02-19 09:14 herman15 New Issue
2014-02-19 09:14 herman15 File Added: sk481_100.stp.zip
2014-02-19 10:20 shoogen Note Added: 0004239
2014-02-19 10:32 herman15 Note Added: 0004240
2014-02-19 11:33 shoogen Relationship added related to 0001411
2014-02-19 11:33 shoogen File Deleted: sk481_100.stp.zip
2014-02-19 11:35 shoogen Summary STEP import failure => STEP import failure due to non-ASCII chars path
2014-03-02 14:04 wmayer Relationship added child of 0000812
2014-03-07 09:36 wmayer Note Added: 0004390
2014-03-07 19:03 yorik Changeset attached => FreeCAD Master master 040c19b1
2014-09-24 11:33 shoogen Note Added: 0005150
2014-09-24 11:35 shoogen Assigned To => shoogen
2014-09-24 11:35 shoogen Status new => assigned
2014-09-24 11:42 shoogen Relationship added parent of 0001763
2014-10-14 18:21 shoogen Status assigned => closed
2014-10-14 18:21 shoogen Resolution open => fixed