View Issue Details

IDProjectCategoryView StatusLast Update
0000133FreeCADBugpublic2010-08-16 07:54
Reporteryorik Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.10 
Summary0000133: inserting a View in an Drawing page that was saved empty causes a crash
DescriptionHi there,
Found this bug today, this is for Jürgen I guess...

to reproduce:

- create a shape
- add a Drawing page
- add a view of the shape to the page
- delete the view
- save the document
- reopen the document
- add again a view of the shape to the page

FreeCAD crashes... I noticed that upon opening the document, an svg view is opened, that contains the shape view, even if such a view was deleted before saving.

Cheers
Y
TagsNo tags attached.
FreeCAD Information

Activities

yorik

2010-08-10 14:40

administrator   ~0000297

It looks like it has to do with if the svg image is displayed or not... Just tried again this, causes the crash too:

- create some geometry
- create a page, add views of the geometry to the page
- save the document
- open the document again
- delete the views, close the svg image view
- add views of the geometry again -> crash

wmayer

2010-08-16 07:54

administrator   ~0000299

No need to save/reload the document. The crash already appears if you close the SVG view and modify the drawing page and do a recompute.

Fixed in rev. 3428

Issue History

Date Modified Username Field Change
2010-08-09 18:40 yorik New Issue
2010-08-10 14:40 yorik Note Added: 0000297
2010-08-16 07:54 wmayer Note Added: 0000299
2010-08-16 07:54 wmayer Assigned To => wmayer
2010-08-16 07:54 wmayer Status new => closed
2010-08-16 07:54 wmayer Resolution open => fixed