View Issue Details

IDProjectCategoryView StatusLast Update
0001298RaytracingFeaturepublic2020-12-03 22:41
Reporterquick61 Assigned Tohowetuft  
PrioritylowSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
PlatformAll suportedOSAll suportedOS VersionAll suported
Fixed in Version0.19 
Summary0001298: Multi-Color Support For Single Part in Raytracing Workbench
DescriptionAs mentioned in https://forum.freecadweb.org/viewtopic.php?f=10&t=4579&start=30#p38074 on the FreeCAD forum, currently the scripts generated by FreeCAD for raytracing can not handle more than one color per part.
Steps To ReproduceFeature Request - No steps to reproduce.
Additional InformationIncreasing the ability of FreeCAD to produce raytracing scripts that contained the information needed to render any single part with multiple colors would be an asset for producing graphical presentations for both personal and professional endeavors.
Tagscolors, Raytracing
FreeCAD Information

Relationships

related to 0002438 closedhowetuft raytracing WB: adding support for multi-color object (fused in a single part) 

Activities

Jriegel

2013-11-06 19:42

administrator   ~0003860

Uh oh... That wont be easy, since the meshing makes the whole part and doesen't know about the faces it came from.

We would have to change the meshing to per face....

yorik

2013-11-06 19:52

administrator   ~0003861

Indeed, but someone could be interested in implementing this at some point, so I suggested to quick61 to add a feature request already... I'll set it to low priority

Kunda1

2020-12-02 11:27

administrator   ~0015048

Last edited: 2020-12-02 11:28

View 2 revisions

@howetuft is this possible in the Render WB ?
(Since Raytracing WB has been superceded by the Render WB)

howetuft

2020-12-02 21:26

developer   ~0015052

Last edited: 2020-12-02 21:27

View 2 revisions

Yes, it is possible if the part is an Assembly, made of subparts (see picture below).
In a more specific way, it is also possible for parts supporting multimaterials (currently restrained to Arch Windows)
Assembly2.png (560,554 bytes)   
Assembly2.png (560,554 bytes)   

Kunda1

2020-12-03 20:30

administrator   ~0015058

@howetuft thanks for replying, what does '(currently restrained to Arch Windows)' mean ?

howetuft

2020-12-03 21:45

developer   ~0015061

Multimaterial feature is currently implemented for Arch Windows, Walls and Panels in FreeCAD (Arch Multimaterial), but I've implemented support only for Arch Windows at the time. You can see an example in the above picture: the windows and the door are made of a brown matte material for the frame and a glass material for the glass panel, all of them embedded in a multimaterial.
Maybe one day I'll extend to Arch Walls and Panels; but it is not very useful for rendering, as the core material is hidden most of the time...

Nota (credits): example below is Villa Savoye model, by paullee, rendered with Appleseed.
Appleseed.png (652,845 bytes)   
Appleseed.png (652,845 bytes)   

Kunda1

2020-12-03 22:38

administrator   ~0015062

@howetuft thank you for the elaboration. So I think we can close this ticket. Perhaps you can open a ticket on Render WB regarding extending Render support beyond Arch Window?

Issue History

Date Modified Username Field Change
2013-11-06 19:12 quick61 New Issue
2013-11-06 19:42 Jriegel Note Added: 0003860
2013-11-06 19:52 yorik Note Added: 0003861
2013-11-06 19:53 yorik Priority none => low
2013-11-06 19:53 yorik Description Updated View Revisions
2017-02-02 21:20 Kunda1 Tag Attached: Raytracing
2017-06-07 21:16 Kunda1 Tag Attached: colors
2017-06-09 22:04 Kunda1 Relationship added related to 0002438
2017-09-24 22:18 wmayer Description Updated View Revisions
2017-12-18 01:17 Kunda1 Project FreeCAD => Raytracing
2020-12-02 11:27 Kunda1 Note Added: 0015048
2020-12-02 11:28 Kunda1 Note Edited: 0015048 View Revisions
2020-12-02 11:36 Kunda1 Tag Attached: #pending-forum
2020-12-02 21:26 howetuft Note Added: 0015052
2020-12-02 21:26 howetuft File Added: Assembly2.png
2020-12-02 21:27 howetuft Note Edited: 0015052 View Revisions
2020-12-03 20:30 Kunda1 Note Added: 0015058
2020-12-03 21:45 howetuft Note Added: 0015061
2020-12-03 21:45 howetuft File Added: Appleseed.png
2020-12-03 22:38 Kunda1 Note Added: 0015062
2020-12-03 22:38 Kunda1 Tag Detached: #pending-forum
2020-12-03 22:41 Kunda1 Assigned To => howetuft
2020-12-03 22:41 Kunda1 Status new => closed
2020-12-03 22:41 Kunda1 Resolution open => fixed
2020-12-03 22:41 Kunda1 Fixed in Version => 0.19