View Issue Details

IDProjectCategoryView StatusLast Update
0001295DraftBugpublic2014-05-03 15:44
Reporterraulshc Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version0.13 
Fixed in Version0.14 
Summary0001295: Snap cursors are not shown when there is an active command
DescriptionDraft cursor neither any of draft snap cursors are shown when one performs a command. See the example screenshot, when line command and midpoint snap are actived. Snapmarker are not affected.

I tested it on WinXP SP3 only. May be the typical Qt/SVG/WinXP endless problem.
Additional InformationOS: Windows XP
Platform: 32-bit
Version: 0.14.2370 (Git)
Branch: master
Hash: a836759ebd91404954a778ff8885e152611576e1
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.5.1
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0001433 closedyorik toolbar symbols of the snap-functions are not show correctly 

Activities

raulshc

2013-11-02 16:51

reporter   ~0003848

The issue is reproduced in 0.13 stable release too.

yorik

2013-11-04 12:48

administrator  

snap_cursors.png (74,210 bytes)   
snap_cursors.png (74,210 bytes)   

yorik

2013-11-20 19:29

administrator   ~0003896

Oops I hadn't seen this.
Is this bug still happening? Any error message appearing on the python console?

raulshc

2013-11-21 17:53

reporter   ~0003898

Yes, the report view yields the following:

pycollada not found, collada support will be disabled.
Draft workbench activated
Pick first point:
Pick next point:
Pick first point:
Pick next point:
Pick first point:
Pick next point:
<type 'exceptions.KeyError'>
<type 'exceptions.KeyError'>
<type 'exceptions.KeyError'>
...

more times


The python console shows:

Python 2.6.2 (r262:71600, Jun 22 2009, 21:44:05) [MSC v.1500 32 bit (Intel)] on win32
Type 'help', 'copyright', 'credits' or 'license' for more information.
>>> App.newDocument()
>>> App.setActiveDocument("Unnamed")
>>> App.ActiveDocument=App.getDocument("Unnamed")
>>> Gui.ActiveDocument=Gui.getDocument("Unnamed")
>>> import Draft
>>> points=[FreeCAD.Vector(-2.11421513557,0.726311922073,0.0),FreeCAD.Vector(7.25220966339,-4.24185800552,0.0)]
>>> Draft.makeWire(points,closed=False,face=False,support=None)
>>> App.getDocument("Unnamed").removeObject("Line")
>>> import Draft
>>> points=[FreeCAD.Vector(-212.378845215,108.159111023,0.0),FreeCAD.Vector(248.005142212,-142.533432007,0.0)]
>>> Draft.makeWire(points,closed=False,face=False,support=None)

yorik

2013-12-22 19:45

administrator   ~0003964

It's hard to know what is happening, there is no error message...
Can you try this in the python window (you must have a document open):

import DraftGui
from PyQt4 import QtGui
print DraftGui.getMainWindow().findChildren(QtGui.QWidget,"QtGLArea")

and paste here any resulting message?
Thanks

raulshc

2013-12-23 00:33

reporter   ~0003968

Document of draft entities opened. Answer is the null array []

>>> import DraftGui
>>> from PyQt4 import QtGui
>>> print DraftGui.getMainWindow().findChildren(QtGui.QWidget,"QtGLArea")
[]
>>>

No report view messages.

yorik

2013-12-23 01:16

administrator   ~0003969

Okay... It doesn't find the 3D view, therefore it doesn't set its cursor. Probably something in Qt that behaves differently on your system. I'll try to find a workaround.

raulshc

2013-12-25 17:57

reporter   ~0003981

The following topic on the forum may be related with this issue:

http://forum.freecadweb.org/viewtopic.php?f=10&t=4613

yorik

2014-01-01 15:30

administrator   ~0003993

Last edited: 2014-01-01 15:31

View 2 revisions

The author of the forum post solved the problem by deleting his .FreeCAD folder. Can you try that too?
*EDIT* Sorry, on windows it is different... Iis the FreeCAD user folder, which must be located in C:/Users/youruser/Application Data/FreeCAD or something similar...

raulshc

2014-01-03 23:32

reporter   ~0004020

That's correct, is located on C:/Users/youruser/Application Data/. I tried this when I readed the post, but didn't work. Snap and snapmarkers work but the draft cursor neither any of draft snap cursors are shown.

Humm, I suspect it may be a bug in the Qt version 4.5.2, I tried with 4.8.1 but FreeCAD crashes so one could not check.

Yorik, change the status of this issue to feedback, I will try to compile the latest source code from git and will test it with recent qt binaries (>=4.8.0) during this month. I will test it with other windows version more modern too.

I'll tell you how it goes.

yorik

2014-01-03 23:48

administrator   ~0004021

Great! Thanks a lot for investigating this further... And indeed it is very likely, ther eis a number of bugs between Qt versions...

microelly2

2014-04-06 12:16

reporter   ~0004533

I have tested it and it works as expected on:

OS: Windows 7
Platform: 32-bit
Version: 0.14.3390 (Git)
Branch: master
Hash: b5b6d49d2e7c0f3fefef3e368cb0b9edd043d757
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.5.1

yorik

2014-04-06 16:13

administrator   ~0004534

Ok, thanks a lot for testing! I'll leave this open a bit more to see if no more reports comes... Unfortunately in the case of windowsXP (as the OP reported), since it's being abandoned by microsoft, there will likely be more and more unfixable bugs on that platform...

microelly2

2014-04-07 10:06

reporter   ~0004537

I have tested my built today on win XP. It works here too.

yorik

2014-05-03 15:44

administrator   ~0004608

I'll close this bug report since it seems things are solved. Reopen if needed!

Issue History

Date Modified Username Field Change
2013-11-02 16:48 raulshc New Issue
2013-11-02 16:48 raulshc File Added: snap_cursors.png
2013-11-02 16:51 raulshc Note Added: 0003848
2013-11-04 12:48 yorik File Deleted: snap_cursors.png
2013-11-04 12:48 yorik File Added: snap_cursors.png
2013-11-20 19:28 yorik Assigned To => yorik
2013-11-20 19:28 yorik Status new => assigned
2013-11-20 19:29 yorik Note Added: 0003896
2013-11-20 19:29 yorik Status assigned => feedback
2013-11-21 17:53 raulshc Note Added: 0003898
2013-11-21 17:53 raulshc Status feedback => assigned
2013-12-22 19:45 yorik Note Added: 0003964
2013-12-22 19:53 yorik Status assigned => feedback
2013-12-23 00:33 raulshc Note Added: 0003968
2013-12-23 00:33 raulshc Status feedback => assigned
2013-12-23 01:16 yorik Note Added: 0003969
2013-12-25 17:57 raulshc Note Added: 0003981
2014-01-01 15:30 yorik Note Added: 0003993
2014-01-01 15:31 yorik Note Edited: 0003993 View Revisions
2014-01-03 23:32 raulshc Note Added: 0004020
2014-01-03 23:48 yorik Note Added: 0004021
2014-01-03 23:49 yorik Status assigned => feedback
2014-02-23 20:47 yorik Relationship added related to 0001433
2014-04-06 12:16 microelly2 Note Added: 0004533
2014-04-06 16:13 yorik Note Added: 0004534
2014-04-07 10:06 microelly2 Note Added: 0004537
2014-05-03 15:44 yorik Note Added: 0004608
2014-05-03 15:44 yorik Status feedback => closed
2014-05-03 15:44 yorik Resolution open => no change required
2014-05-03 15:44 yorik Fixed in Version => 0.14