View Issue Details

IDProjectCategoryView StatusLast Update
0001148FreeCADBugpublic2014-01-18 07:19
Reporterthayerov Assigned Towmayer  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Summary0001148: Incorrect STL from a mesh
DescriptionSTL file doesn't save an internal surface after using difference operation for a mesh.
TagsNo tags attached.
FreeCAD Information

Activities

2013-06-10 14:36

 

bug2.png (Attachment missing)

wmayer

2013-06-11 06:26

administrator   ~0003193

So, is it an error in the STL export (which I doubt it is) or an error in the difference operation (more likely)? It would be good to have some example data to reproduce this behaviour.

2013-06-11 07:24

 

bug.FCMacro (Attachment missing)

thayerov

2013-06-11 07:25

reporter   ~0003194

I have added a macro, which generates this STL.

Jriegel

2013-06-26 09:22

administrator   ~0003244

The boolean operations on meshes are unstable.
I don't think we will fix them in the near future.

Since this is a CAD system I would advice to use the CAD datastructure to create the geometry and then export it to a mesh....

modeler123

2013-11-23 18:50

reporter   ~0003901

I have replicated the same issue using the draft and part design modules. To replicate issue:

Create circle in draft
Create pad in part design
Create circle in draft on top face of cylinder in draft
Create pocket from circle into cylinder in part design
Select all
Export to stl or step or iges
All exports result in no internal cavity appearing

Is there a workaround for this? If not, I would say that this is a major issue.

normandc

2013-11-25 05:08

manager   ~0003904

Last edited: 2013-11-25 05:09

View 2 revisions

modeler123, your report's usefulness is limited if you do not provide your FreeCAD version and OS.

I have done as you said, and step, iges and stl exported fine.

I should also add that you should NOT select all prior to export. Only select the last feature in the tree, which is the pocket.

OS: Ubuntu 12.04.3 LTS
Platform: 64-bit
Version: 0.14.2771 (Git)
Branch: master
Hash: 3153ccd8b2da6a4155d6986da8c07d22a6163be1
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0

shoogen

2014-01-15 23:11

developer   ~0004080

Last edited: 2014-01-15 23:12

View 2 revisions

If you have OpenSCAD installed you can use it to perform the boolean operations (see the attached modified Macro)

shoogen

2014-01-15 23:11

developer  

workaround.FCMacro (Attachment missing)

wmayer

2014-01-16 09:10

administrator   ~0004082

Then maybe it's best to replace the mesh boolean operations by OpenSCAD functions.

shoogen

2014-01-16 09:38

developer   ~0004083

We can't ship OpenSCAD with FreeCAD because of the GPL. And we can't link CGAL directly because of the GPL.

wmayer

2014-01-16 09:53

administrator   ~0004084

Last edited: 2014-01-16 10:58

View 3 revisions

I don't consider this a problem because it should be no problem for a user to install it manually.

Besides this theoretically it won't be a problem to ship OpenSCAD with FreeCAD because it doesn't *link* OpenSCAD but runs the executable. This means the GPL doesn't consider this a *derived* work but an *aggregated* work and thus won't affect FreeCAD.

Jriegel

2014-01-18 07:19

administrator   ~0004091

Thats actually a good idea to use OpenSCAD as an external program to solve our mesh boolean problem.

Related Changesets

FreeCAD: master 795bd01f

2014-01-16 11:55:32

wmayer

Details Diff
+ fixes 0001148: Incorrect STL from a mesh Affected Issues
0001148
mod - src/Mod/Mesh/Gui/Command.cpp Diff File

Issue History

Date Modified Username Field Change
2013-06-10 14:36 thayerov New Issue
2013-06-10 14:36 thayerov File Added: bug2.png
2013-06-11 06:26 wmayer Note Added: 0003193
2013-06-11 07:24 thayerov File Added: bug.FCMacro
2013-06-11 07:25 thayerov Note Added: 0003194
2013-06-26 09:22 Jriegel Note Added: 0003244
2013-06-26 09:22 Jriegel Status new => acknowledged
2013-11-23 18:50 modeler123 Note Added: 0003901
2013-11-25 05:08 normandc Note Added: 0003904
2013-11-25 05:09 normandc Note Edited: 0003904 View Revisions
2014-01-15 23:11 shoogen Note Added: 0004080
2014-01-15 23:11 shoogen File Added: workaround.FCMacro
2014-01-15 23:12 shoogen Note Edited: 0004080 View Revisions
2014-01-16 09:10 wmayer Note Added: 0004082
2014-01-16 09:38 shoogen Note Added: 0004083
2014-01-16 09:53 wmayer Note Added: 0004084
2014-01-16 10:57 wmayer Note Edited: 0004084 View Revisions
2014-01-16 10:57 wmayer Changeset attached => FreeCAD Master master 795bd01f
2014-01-16 10:57 wmayer Assigned To => wmayer
2014-01-16 10:57 wmayer Status acknowledged => closed
2014-01-16 10:57 wmayer Resolution open => fixed
2014-01-16 10:58 wmayer Note Edited: 0004084 View Revisions
2014-01-18 07:19 Jriegel Note Added: 0004091