View Issue Details

IDProjectCategoryView StatusLast Update
0004170TechDrawBugpublic2020-01-14 14:22
Reporterwandererfan Assigned Towandererfan  
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status closedResolutionfixed 
PlatformWindows 
Product Version0.18 
Target Version0.19Fixed in Version0.19 
Summary0004170: TechDraw: Unicode Character Problem in SVG Export
DescriptionSome users report problems with SVG exports of TD Pages if the page contains characters with diacritical marks (umlaut, tilde, etc). SVG file will not display in browsers, but will display in Inkscape.

Forum discussion
Steps To ReproduceCould not reproduce on Linux Mint.
OS: Linux Mint 19 (X-Cinnamon/cinnamon)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.18536 +4 (Git)
Build type: debug
Branch: staleViews
Hash: 1a1aa0e2a749eb5e4e3a8d4609a1f6c61072804f
Python version: 3.6.8
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/Canada (en_CA)
Tagsunicode
FreeCAD InformationOS: Linux Mint 19 (X-Cinnamon/cinnamon)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.18536 +4 (Git)
Build type: debug
Branch: staleViews
Hash: 1a1aa0e2a749eb5e4e3a8d4609a1f6c61072804f
Python version: 3.6.8
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/Canada (en_CA)

Activities

wandererfan

2019-10-19 00:06

manager   ~0013766

Both reporters are using Windows. Can this be Windows only?

uwestoehr

2019-12-09 22:58

developer   ~0013890

I have the same problem using Windows:
https://forum.freecadweb.org/viewtopic.php?f=35&t=41559

It is not about Spanish characters, it is a Unicode issue. And indeed, it seems to be Windows-only.

OS: Windows 7 SP 1 (6.1)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.18859 +3 (Git)
Build type: Release
Branch: TD_fix-XY-change
Hash: bff3579434fb4881d60ac299da4eb2f9621deb9d
Python version: 3.6.8
Qt version: 5.12.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Germany (de_DE)

Kunda1

2019-12-11 11:45

administrator   ~0013896

Updated ticket title + tagged ticket

wandererfan

2020-01-13 01:02

manager   ~0014065

for future reference:
on Mint
ÄÖÜß becomes C3 84 C3 96 C3 9C C3 9F (utf8)

On Win
ÄÖÜß becomes C4 06 DC DF (Latin-1 (ISO-8859-1) )

Same code.

wandererfan

2020-01-14 12:37

manager   ~0014070

Fix committed to master branch.

Kunda1

2020-01-14 14:22

administrator   ~0014071

Thanks wandererfan!
BTW, marked 'Fixed in v0.19' (not sure why Source Integration plugin didn't do that?)

Related Changesets

FreeCAD: master 1da11e4e

2020-01-13 19:12:17

wandererfan

Details Diff
[TD]fix 0004170 Unicode in Svg export on Win Affected Issues
0004170
mod - src/Mod/TechDraw/Gui/QGVPage.cpp Diff File

Issue History

Date Modified Username Field Change
2019-10-19 00:05 wandererfan New Issue
2019-10-19 00:06 wandererfan Note Added: 0013766
2019-12-09 22:58 uwestoehr Note Added: 0013890
2019-12-11 11:44 Kunda1 Summary Spanish/German Character Problem in SVG Export => TechDraw: Unicode Character Problem in SVG Export
2019-12-11 11:44 Kunda1 Tag Attached: unicode
2019-12-11 11:45 Kunda1 Note Added: 0013896
2019-12-11 11:45 Kunda1 Status new => confirmed
2020-01-13 01:02 wandererfan Note Added: 0014065
2020-01-14 12:37 wandererfan Changeset attached => FreeCAD master 1da11e4e
2020-01-14 12:37 wandererfan Note Added: 0014070
2020-01-14 12:37 wandererfan Assigned To => wandererfan
2020-01-14 12:37 wandererfan Status confirmed => closed
2020-01-14 12:37 wandererfan Resolution open => fixed
2020-01-14 14:22 Kunda1 Fixed in Version => 0.19
2020-01-14 14:22 Kunda1 Note Added: 0014071