View Revisions: Issue #2868

Summary 0002868: Port QtWebKit to QtWebEngine
Revision 2019-01-16 13:21 by Kunda1
Description As of Qt 5.6, QtWebKit is deprecated in favor of QtWebEngine. The QtWebKit source is still available but not included in any Qt 5.6 or later distros.

Currently the Web Mod depends upon QtWebKit causing exceptions upon launch when built without QtWebKit

Qt 5.7 is already out and the plan is for FreeCAD 0.17 to release on Qt 5.x so we need to find a path to remove the dependency on QtWebKit.
Revision 2017-01-21 20:34 by blacey
Description As of Qt 5.6, QtWebKit is deprecated in favor of QtWebKitEngine. The QtWebKit source is still available but not included in any Qt 5.6 or later distros.

Currently the Web Mod depends upon QtWebKit causing exceptions upon launch when built without QtWebKit

Qt 5.7 is already out and the plan is for FreeCAD 0.17 to release on Qt 5.x so we need to find a path to remove the dependency on QtWebKit.